500 error for one specific user

Hi all,

I’m currently using LDAP for login and it works great with all my users,
except for one (me!). Out of no where one day I could no longer login,
but when I click on a ticket I begin getting "500 internal server error"
for everything I try to do (even go to the site’s root). I also see the
below in the logs. I’ve tried everything I can think of to fix this, and
have made no progress. I cannot delete the user as a large number of
tickets in the history are assigned to this user. Keep in mind this ONLY
effects my user account. I’ve tried it on a number of PCs, even PCs
where another users account works. The other accounts work OK on mine as
well. I’m guessing there is some corrupt data in the database somewhere.
Any help is very much appreciated!

I’ve also tried this without FastCGI and see the same result. :frowning:

==> /var/log/apache/error_log <==
Out of memory!
[Mon May 1 11:26:19 2006] [error] [client 130.85.2.75] FastCGI:
incomplete headers (0 bytes) received from server
"/var/www/rt.ptt.org/rt-3.4.5/bin/mason_handler.fcgi"
[Mon May 1 11:26:19 2006] [warn] FastCGI: server
"/var/www/rt.ptt.org/rt-3.4.5/bin/mason_handler.fcgi" (pid 22336)
terminated by calling exit with status ‘1’
[Mon May 1 11:26:19 2006] [warn] FastCGI: server
"/var/www/rt.ptt.org/rt-3.4.5/bin/mason_handler.fcgi" (uid 1002, gid
9106) restarted (pid 23087)

TIA,

Daniel Jimenez

I FINALLY figured this out. It had to do with one of the columns in my
user account. I nulled everything and it finally fixed it. Man that was
frustrating!!!

Hope this helps someone in the future!

Daniel-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Daniel
Jimenez
Sent: Monday, May 01, 2006 11:33 AM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] 500 error for one specific user…

Hi all,

I’m currently using LDAP for login and it works great with all my users,
except for one (me!). Out of no where one day I could no longer login,
but when I click on a ticket I begin getting "500 internal server error"
for everything I try to do (even go to the site’s root). I also see the
below in the logs. I’ve tried everything I can think of to fix this, and
have made no progress. I cannot delete the user as a large number of
tickets in the history are assigned to this user. Keep in mind this ONLY
effects my user account. I’ve tried it on a number of PCs, even PCs
where another users account works. The other accounts work OK on mine as
well. I’m guessing there is some corrupt data in the database somewhere.
Any help is very much appreciated!

I’ve also tried this without FastCGI and see the same result. :frowning:

==> /var/log/apache/error_log <==
Out of memory!
[Mon May 1 11:26:19 2006] [error] [client 130.85.2.75] FastCGI:
incomplete headers (0 bytes) received from server
"/var/www/rt.ptt.org/rt-3.4.5/bin/mason_handler.fcgi"
[Mon May 1 11:26:19 2006] [warn] FastCGI: server
"/var/www/rt.ptt.org/rt-3.4.5/bin/mason_handler.fcgi" (pid 22336)
terminated by calling exit with status ‘1’
[Mon May 1 11:26:19 2006] [warn] FastCGI: server
"/var/www/rt.ptt.org/rt-3.4.5/bin/mason_handler.fcgi" (uid 1002, gid
9106) restarted (pid 23087)

TIA,

Daniel Jimenez
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

We’re hiring! Come hack Perl for Best Practical: