500 error Configuring rt-mailgate


#1

Hello,

I’m hoping someone can provide me a new place to check for some
troubleshooting on this issue. I’m trying to configure RT to handle
incoming mail, but I keep getting an error that I can’t find much
information on.

I’m using the following to test my configuration:

(echo from: test @ testmail.com Subject: test; echo; echo test) | /var/www/rt-live/bin/rt-mailgate --queue General --action correspond --no-verify-ssl --url https:// rt.domain .com/rt --debug

(Spaces added to addresses due to discourse limitations on links being present for new users)

and I receive the following error:

HTTP request failed: 500 Can’t connect to rt. domain. com:443 (Connection timed out). Your webserver logs may have more information or there may be a network problem.

My webserver logs contain no additional information on the error

The system is a Centos 7 Machine, SELinux is disabled. Using apache. The one thing I can think of that could be causing it would be the use of a SSO external auth(shibboleth) as a part of the apache config, but I’ve tried disabling that with no luck.

At this point I don’t really know where to begin looking, any suggestions would be appreciated.


#2

Have you tried adding quotes? Not sure if that would be the issue, but it’s worth a try. This is an example entry in our aliases file:

rt-mail-address: "|/opt/rt4/bin/rt-mailgate --no-verify-ssl --queue 'Case Sensitive Name Of Queue' --action correspond --url https://some.domain.io/rt"

Other then that, I’m going to assume that a simple request from the mailserver to the RT server actually works:

wget --spider --no-check-certificate https://some.domain.io/rt