3.8.3 breaks AssetTracker 1.2.4b1

Peter,

I’ll look into it during the next week. Can you restore your previous
RT version until then?

-ToddOn Wed, Jun 3, 2009 at 5:46 PM, Peter C. Lai peter@simons-rock.edu wrote:

Bumping rt to 3.8.3 from 3.8.2 breaks Todd’s Asset Tracker plugin
(1.2.4b1 from googlecode svn)

The plugin fails when accessing the module’s overlay from RT with an error
like:

ACLEquivalenceObjects method not accessible from RTx::AssetTracker::System

Peter C. Lai | Bard College at Simon’s Rock
Systems Administrator | 84 Alford Rd.
Information Technology Svcs. | Gt. Barrington, MA 01230 USA
peter AT simons-rock.edu | (413) 528-7428

there is already solution posted on the list, sorry for that.On Thu, Jun 4, 2009 at 10:40 PM, Todd Chapman todd@chaka.net wrote:

Peter,

I’ll look into it during the next week. Can you restore your previous
RT version until then?

-Todd

On Wed, Jun 3, 2009 at 5:46 PM, Peter C. Lai peter@simons-rock.edu wrote:

Bumping rt to 3.8.3 from 3.8.2 breaks Todd’s Asset Tracker plugin
(1.2.4b1 from googlecode svn)

The plugin fails when accessing the module’s overlay from RT with an error
like:

ACLEquivalenceObjects method not accessible from RTx::AssetTracker::System

Peter C. Lai | Bard College at Simon’s Rock
Systems Administrator | 84 Alford Rd.
Information Technology Svcs. | Gt. Barrington, MA 01230 USA
peter AT simons-rock.edu | (413) 528-7428


List info: http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-devel

Best regards, Ruslan.

I am assuming you are referring to:
http://lists.bestpractical.com/pipermail/rt-users/2009-June/059446.html

And for reference, here’s the exact error I get:

I am in RT -> Configuration -> Asset Types

(/AssetTracker/Admin/Types/index.html)

Can’t locate object method “ACLEquivalenceObjects” via package “RTx::AssetTracker::System” at /usr/pkg/lib/rt3/RT/Principal_Overlay.pm line 327.

The fix you gave fixed the issue.On 2009-06-04 10:48:44PM +0400, Ruslan Zakirov wrote:

there is already solution posted on the list, sorry for that.

On Thu, Jun 4, 2009 at 10:40 PM, Todd Chapman todd@chaka.net wrote:

Peter,

I’ll look into it during the next week. Can you restore your previous
RT version until then?

-Todd

On Wed, Jun 3, 2009 at 5:46 PM, Peter C. Lai peter@simons-rock.edu wrote:

Bumping rt to 3.8.3 from 3.8.2 breaks Todd’s Asset Tracker plugin
(1.2.4b1 from googlecode svn)

The plugin fails when accessing the module’s overlay from RT with an error
like:

ACLEquivalenceObjects method not accessible from RTx::AssetTracker::System

Peter C. Lai � � � � � � � � | Bard College at Simon’s Rock
Systems Administrator � � � �| 84 Alford Rd.
Information Technology Svcs. | Gt. Barrington, MA 01230 USA
peter AT simons-rock.edu � � | (413) 528-7428


List info: http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-devel


Best regards, Ruslan.

Peter C. Lai | Bard College at Simon’s Rock
Systems Administrator | 84 Alford Rd.
Information Technology Svcs. | Gt. Barrington, MA 01230 USA
peter AT simons-rock.edu | (413) 528-7428