3.6.6 display problem

Hi, I’m running SLES 10, SP1, with RT 3.6.6. Yesterday, I installed 2 php5 modules, then ran online updates last night from YAST2, and today I see nothing when I access the site, just a blank page.

The Apache access_log shows a successful connection:
172.31.4.143 - - [10/Sep/2008:10:43:55 -0400] “GET /index.html HTTP/1.1” 200 - “-” “Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1”

But Firefox displays a blank page, 0 bytes. I’m guessing it’s a Perl module from the YAST update. Any clues?

The information in this message may be proprietary and/or confidential, and protected from disclosure. If the reader of this message is not the intended recipient, or an employee or agent responsible for delivering this message to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify Stonebridge Bank immediately by replying to this message and deleting it from your computer.

Yeah, ‘rpm -qa --last | less’ showed me that perl-5.8.8-14.10 was
installed Wed Sep 10 03:26:19 2008.

I tried to reinstall Scalar::Utils but I’m having some trouble with
CPAN — any suggestions?

cpan[1]> install Scalar::Utils
CPAN: Storable loaded ok (v2.15)
Going to read /root/.cpan/Metadata
Database was generated on Thu, 05 Jun 2008 19:06:52 GMT
Going to read /root/.cpan/sources/authors/01mailrc.txt.gz
Use of uninitialized value in concatenation (.) or string at
/usr/lib/perl5/5.8.8/i586-linux-thread-multi/Scalar/Util.pm line 30.
Use of uninitialized value in concatenation (.) or string at
/usr/lib/perl5/5.8.8/i586-linux-thread-multi/Scalar/Util.pm line 30.
…DONE
CPAN: LWP::UserAgent loaded ok (v2.036)
CPAN: Time::HiRes loaded ok (v1.86)
Fetching with LWP:

ftp://bc1.hpc.lsu.edu/pub/mirrors/CPAN/modules/02packages.details.txt.gz

Use of uninitialized value in concatenation (.) or string at
/usr/lib/perl5/5.8.8/i586-linux-thread-multi/Scalar/Util.pm line 30.

LWP failed with code[500] message[read timeout]
CPAN: Net::FTP loaded ok (v2.77)
Fetching with Net::FTP:

ftp://bc1.hpc.lsu.edu/pub/mirrors/CPAN/modules/02packages.details.txt.gz

Couldn’t cwd pub/mirrors/CPAN/modules: pub/mirrors/CPAN/modules: No
such file or directory.
Fetching with Net::FTP

ftp://bc1.hpc.lsu.edu/pub/mirrors/CPAN/modules/02packages.details.txt.gz.gz

Couldn’t cwd pub/mirrors/CPAN/modules: pub/mirrors/CPAN/modules: No
such file or directory.

Trying with “/usr/bin/wget -O
/root/.cpan/sources/modules/02packages.details.txt.tmp22613” to get

ftp://bc1.hpc.lsu.edu/pub/mirrors/CPAN/modules/02packages.details.txt.gz

–11:36:08–
ftp://bc1.hpc.lsu.edu/pub/mirrors/CPAN/modules/02packages.details.txt.gz

       =>

`/root/.cpan/sources/modules/02packages.details.txt.tmp22613’
Connecting to 172.31.4.254:8080… connected.
Proxy request sent, awaiting response… 404 Not Found
11:36:10 ERROR 404: Not Found.

System call "/usr/bin/wget -O

/root/.cpan/sources/modules/02packages.details.txt.tmp22613
"ftp://bc1.hpc.lsu.edu/pub/mirrors/CPAN/modules/02packages.details.txt.gz"
"
returned status 1 (wstat 256)
Warning: expected file
[/root/.cpan/sources/modules/02packages.details.txt.gz.tmp22613] doesn’t
exist
Fetching with LWP:
ftp://cpan.calvin.edu/pub/CPAN/modules/02packages.details.txt.gz
CPAN: YAML loaded ok (v0.66)
Going to read /root/.cpan/sources/modules/02packages.details.txt.gz
Catching error: ‘Undefined subroutine &Compress::Zlib::gzopen called at
/usr/lib/perl5/5.8.8/CPAN/Tarzip.pm line 103.
’ at /usr/lib/perl5/5.8.8/CPAN.pm line 281
CPAN::shell() called at -e line 1
Going to read /root/.cpan/sources/authors/01mailrc.txt.gz
Lockfile removed.
Undefined subroutine &Compress::Zlib::gzopen called at
/usr/lib/perl5/5.8.8/CPAN/Tarzip.pm line 103.

“Michael James” MJames@stonebridgebank.com 9/10/2008 10:57 AM

Hi, I’m running SLES 10, SP1, with RT 3.6.6. Yesterday, I installed 2
php5 modules, then ran online updates last night from YAST2, and today I
see nothing when I access the site, just a blank page.

The Apache access_log shows a successful connection:
172.31.4.143 - - [10/Sep/2008:10:43:55 -0400] “GET /index.html
HTTP/1.1” 200 - “-” “Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1”

But Firefox displays a blank page, 0 bytes. I’m guessing it’s a Perl
module from the YAST update. Any clues?

The information in this message may be proprietary and/or confidential,
and protected from disclosure. If the reader of this message is not the
intended recipient, or an employee or agent responsible for delivering
this message to the intended recipient, you are hereby notified that any
dissemination, distribution or copying of this communication is strictly
prohibited. If you have received this communication in error, please
notify Stonebridge Bank immediately by replying to this message and
deleting it from your computer.
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

The information in this message may be proprietary and/or confidential,
and protected from disclosure. If the reader of this message is not the
intended recipient, or an employee or agent responsible for delivering
this message to the intended recipient, you are hereby notified that any
dissemination, distribution or copying of this communication is strictly
prohibited. If you have received this communication in error, please
notify Stonebridge Bank immediately by replying to this message and
deleting it from your computer.

OK, I did ‘force install Scalar::Util’ and that worked for me. The login
page displays properly. Still working on Compress::Zlib …

Thanks for listening,
Mike
:slight_smile:

“Michael James” MJames@stonebridgebank.com 9/10/2008 11:38 AM

Yeah, ‘rpm -qa --last | less’ showed me that perl-5.8.8-14.10 was
installed Wed Sep 10 03:26:19 2008.

I tried to reinstall Scalar::Utils but I’m having some trouble with
CPAN — any suggestions?

cpan[1]> install Scalar::Utils
CPAN: Storable loaded ok (v2.15)
Going to read /root/.cpan/Metadata
Database was generated on Thu, 05 Jun 2008 19:06:52 GMT
Going to read /root/.cpan/sources/authors/01mailrc.txt.gz
Use of uninitialized value in concatenation (.) or string at
/usr/lib/perl5/5.8.8/i586-linux-thread-multi/Scalar/Util.pm line 30.
Use of uninitialized value in concatenation (.) or string at
/usr/lib/perl5/5.8.8/i586-linux-thread-multi/Scalar/Util.pm line 30.
…DONE
CPAN: LWP::UserAgent loaded ok (v2.036)
CPAN: Time::HiRes loaded ok (v1.86)
Fetching with LWP:

ftp://bc1.hpc.lsu.edu/pub/mirrors/CPAN/modules/02packages.details.txt.gz

Use of uninitialized value in concatenation (.) or string at
/usr/lib/perl5/5.8.8/i586-linux-thread-multi/Scalar/Util.pm line 30.

LWP failed with code[500] message[read timeout]
CPAN: Net::FTP loaded ok (v2.77)
Fetching with Net::FTP:

ftp://bc1.hpc.lsu.edu/pub/mirrors/CPAN/modules/02packages.details.txt.gz

Couldn’t cwd pub/mirrors/CPAN/modules: pub/mirrors/CPAN/modules: No
such file or directory.
Fetching with Net::FTP

ftp://bc1.hpc.lsu.edu/pub/mirrors/CPAN/modules/02packages.details.txt.gz.gz

Couldn’t cwd pub/mirrors/CPAN/modules: pub/mirrors/CPAN/modules: No
such file or directory.

Trying with “/usr/bin/wget -O
/root/.cpan/sources/modules/02packages.details.txt.tmp22613” to get

ftp://bc1.hpc.lsu.edu/pub/mirrors/CPAN/modules/02packages.details.txt.gz

–11:36:08–
ftp://bc1.hpc.lsu.edu/pub/mirrors/CPAN/modules/02packages.details.txt.gz

       =>

`/root/.cpan/sources/modules/02packages.details.txt.tmp22613’
Connecting to 172.31.4.254:8080… connected.
Proxy request sent, awaiting response… 404 Not Found
11:36:10 ERROR 404: Not Found.

System call "/usr/bin/wget -O

/root/.cpan/sources/modules/02packages.details.txt.tmp22613
"ftp://bc1.hpc.lsu.edu/pub/mirrors/CPAN/modules/02packages.details.txt.gz"
"
returned status 1 (wstat 256)
Warning: expected file
[/root/.cpan/sources/modules/02packages.details.txt.gz.tmp22613]
doesn’t
exist
Fetching with LWP:
ftp://cpan.calvin.edu/pub/CPAN/modules/02packages.details.txt.gz
CPAN: YAML loaded ok (v0.66)
Going to read /root/.cpan/sources/modules/02packages.details.txt.gz
Catching error: ‘Undefined subroutine &Compress::Zlib::gzopen called
at
/usr/lib/perl5/5.8.8/CPAN/Tarzip.pm line 103.
’ at /usr/lib/perl5/5.8.8/CPAN.pm line 281
CPAN::shell() called at -e line 1
Going to read /root/.cpan/sources/authors/01mailrc.txt.gz
Lockfile removed.
Undefined subroutine &Compress::Zlib::gzopen called at
/usr/lib/perl5/5.8.8/CPAN/Tarzip.pm line 103.

“Michael James” MJames@stonebridgebank.com 9/10/2008 10:57 AM

Hi, I’m running SLES 10, SP1, with RT 3.6.6. Yesterday, I installed 2
php5 modules, then ran online updates last night from YAST2, and today
I
see nothing when I access the site, just a blank page.

The Apache access_log shows a successful connection:
172.31.4.143 - - [10/Sep/2008:10:43:55 -0400] “GET /index.html
HTTP/1.1” 200 - “-” “Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1”

But Firefox displays a blank page, 0 bytes. I’m guessing it’s a Perl
module from the YAST update. Any clues?

The information in this message may be proprietary and/or
confidential,
and protected from disclosure. If the reader of this message is not
the
intended recipient, or an employee or agent responsible for delivering
this message to the intended recipient, you are hereby notified that
any
dissemination, distribution or copying of this communication is
strictly
prohibited. If you have received this communication in error, please
notify Stonebridge Bank immediately by replying to this message and
deleting it from your computer.
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

The information in this message may be proprietary and/or
confidential,
and protected from disclosure. If the reader of this message is not
the
intended recipient, or an employee or agent responsible for delivering
this message to the intended recipient, you are hereby notified that
any
dissemination, distribution or copying of this communication is
strictly
prohibited. If you have received this communication in error, please
notify Stonebridge Bank immediately by replying to this message and
deleting it from your computer.
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

The information in this message may be proprietary and/or confidential,
and protected from disclosure. If the reader of this message is not the
intended recipient, or an employee or agent responsible for delivering
this message to the intended recipient, you are hereby notified that any
dissemination, distribution or copying of this communication is strictly
prohibited. If you have received this communication in error, please
notify Stonebridge Bank immediately by replying to this message and
deleting it from your computer.