3.4.2 RT on SuSE, mail being sent as nobody

This issue is really racking my brain. We were on 3.2.2 before on
another box and never had a problem receiving mail. Now we have moved
to a different server with the SuSE 9.1 same as the prior, but with RT
3.4.2. Now we are having issues where requestors firewalls are
filtering responses as spam because it seems them being sent as
nobody@domain.com

When I look at the headers the return-path is nobody@domain.com but
the reply-to and from are from rtqueue@domain.com which seems right.

I have been looking at all my config files and settings and am unable
to see anything improperly setup. Did something change between the
two versions of RT that is causing this to act different?

-Juan

As far as I understand your Apache(RT) runs under nobody user, but RT
sends mail with “from” header field different from
’nobody@your_domain.com’, so sendmail adds info that real author was
’nobody’. There is trusted users config file in the sendmail, but it’s
not good idea to make nobody trusted sendmail user. Create new
user/group for apache, change apache config, add this user to trusted
list, after this sendmail wouldn’t be adding info about real author of
the mail.On 7/27/05, Juan Mas juan.mas@gmail.com wrote:

This issue is really racking my brain. We were on 3.2.2 before on
another box and never had a problem receiving mail. Now we have moved
to a different server with the SuSE 9.1 same as the prior, but with RT
3.4.2. Now we are having issues where requestors firewalls are
filtering responses as spam because it seems them being sent as
nobody@domain.com

When I look at the headers the return-path is nobody@domain.com but
the reply-to and from are from rtqueue@domain.com which seems right.

I have been looking at all my config files and settings and am unable
to see anything improperly setup. Did something change between the
two versions of RT that is causing this to act different?


-Juan


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Best regards, Ruslan.

The odd thing is, I essentially copied the Apache folder from the old
server and am using it as it was now on the new server. So Im not
sure that it would be an apache issue. Everything, as far as I can
tell, is setup exactly as it was on the old server, the only
discrepency being a newer version of RT on the new server. So I wasnt
sure if it was now handling mail a bit differently or not.On 7/26/05, Ruslan Zakirov ruslan.zakirov@gmail.com wrote:

As far as I understand your Apache(RT) runs under nobody user, but RT
sends mail with “from” header field different from
’nobody@your_domain.com’, so sendmail adds info that real author was
’nobody’. There is trusted users config file in the sendmail, but it’s
not good idea to make nobody trusted sendmail user. Create new
user/group for apache, change apache config, add this user to trusted
list, after this sendmail wouldn’t be adding info about real author of
the mail.

On 7/27/05, Juan Mas juan.mas@gmail.com wrote:

This issue is really racking my brain. We were on 3.2.2 before on
another box and never had a problem receiving mail. Now we have moved
to a different server with the SuSE 9.1 same as the prior, but with RT
3.4.2. Now we are having issues where requestors firewalls are
filtering responses as spam because it seems them being sent as
nobody@domain.com

When I look at the headers the return-path is nobody@domain.com but
the reply-to and from are from rtqueue@domain.com which seems right.

I have been looking at all my config files and settings and am unable
to see anything improperly setup. Did something change between the
two versions of RT that is causing this to act different?


-Juan


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com


Best regards, Ruslan.

-Juan

Juan Mas wrote:

The odd thing is, I essentially copied the Apache folder from the old
server and am using it as it was now on the new server. So Im not
sure that it would be an apache issue. Everything, as far as I can
tell, is setup exactly as it was on the old server, the only
discrepency being a newer version of RT on the new server. So I wasnt
sure if it was now handling mail a bit differently or not.

The behavious of apache on SuSE is also controlled by
/etc/sysconfig/apache - unless you use a self-compiled apache.

Also, compare your postfix-settings.

cheers,
Rainer

Juan, problem is not in apache, problem in your MTA, you have to add
user(which apache use) to trusted users in sendmail config!On 7/27/05, Rainer Duffner rainer@ultra-secure.de wrote:

Juan Mas wrote:

The odd thing is, I essentially copied the Apache folder from the old
server and am using it as it was now on the new server. So Im not
sure that it would be an apache issue. Everything, as far as I can
tell, is setup exactly as it was on the old server, the only
discrepency being a newer version of RT on the new server. So I wasnt
sure if it was now handling mail a bit differently or not.

The behavious of apache on SuSE is also controlled by
/etc/sysconfig/apache - unless you use a self-compiled apache.

Also, compare your postfix-settings.

cheers,
Rainer


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Best regards, Ruslan.