3.0 import error

I’ve successfully exported my RT 2.0.11 database.

I am now trying to import into 3.0.8. After importing the users, I get this:

Importing groups
gggggggrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrr[Tue Jan 13
21:55:50 2004] [crit]: 1 (/local/rt3/lib/RT/ACE_Overlay.pm:884)
[Tue Jan 13 21:55:50 2004] [crit]: Can’t load a principal for id
(/local/rt3/lib/RT/ACE_Overlay.pm:885)
rrrrrrrrrrrq[Tue Jan 13 21:55:54 2004] [crit]: Can’t locate object
method “new” via package “RT::Scrip” (perhaps you forgot to load
"RT::Scrip"?) at ./dumpfile-to-rt-3.0 line 387.
(/local/rt3/lib/RT.pm:254)

Is this an error in the script, config error, or an error in my data?

Thanks in advance!

Russ

I have exactly the same problem now.

AndreyOn Tue, Jan 13, 2004 at 02:48:02PM -0800, Russ Johnson wrote:

I’ve successfully exported my RT 2.0.11 database.

I am now trying to import into 3.0.8. After importing the users, I get this:

Importing groups
gggggggrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrr[Tue Jan 13
21:55:50 2004] [crit]: 1 (/local/rt3/lib/RT/ACE_Overlay.pm:884)
[Tue Jan 13 21:55:50 2004] [crit]: Can’t load a principal for id
(/local/rt3/lib/RT/ACE_Overlay.pm:885)
rrrrrrrrrrrq[Tue Jan 13 21:55:54 2004] [crit]: Can’t locate object
method “new” via package “RT::Scrip” (perhaps you forgot to load
“RT::Scrip”?) at ./dumpfile-to-rt-3.0 line 387.
(/local/rt3/lib/RT.pm:254)

Is this an error in the script, config error, or an error in my data?

Thanks in advance!

Russ


rt-users mailing list
rt-users@lists.bestpractical.com
The rt-users Archives

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

I even checked to make sure RT::Scrip.pm is in /local/rt3/lib.

It is.

Andrey Vovk wrote:

Russ Johnson wrote:

rrrrrrrrrrrq[Tue Jan 13 21:55:54 2004] [crit]: Can’t locate object
method “new” via package “RT::Scrip” (perhaps you forgot to load
“RT::Scrip”?) at ./dumpfile-to-rt-3.0 line 387.
(/local/rt3/lib/RT.pm:254)

Is this an error in the script, config error, or an error in my data?

IIRC, you need to add a line “use RT::Scrip” to dumpfile-to-rt-3.0,
and this is already fixed in the repository, pending a new release
of the upgrade tools.
�|� Request Tracker... So much more than a help desk — Best Practical Solutions – Trouble Ticketing. Free.

Phil Homewood wrote:

IIRC, you need to add a line “use RT::Scrip” to dumpfile-to-rt-3.0,
and this is already fixed in the repository, pending a new release
of the upgrade tools.

OK, it imports the users fine, then I get this:

Importing groups
gggggggrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrr[Wed Jan 14
23:42:34 2004] [crit]: 1 (/local/rt3/lib/RT/ACE_Overlay.pm:884)
[Wed Jan 14 23:42:34 2004] [crit]: Can’t load a principal for id
(/local/rt3/lib/RT/ACE_Overlay.pm:885)
rrrrrrrrrrrqqqqqqImporting tickets…t-1
.t-2
.t-3

So, it appears I’ve added the proper line outlined above.

Any clues as to what this error means?

Thanks!

Russ

Russ Johnson wrote:

Phil Homewood wrote:

IIRC, you need to add a line “use RT::Scrip” to dumpfile-to-rt-3.0,
and this is already fixed in the repository, pending a new release
of the upgrade tools.

OK, it imports the users fine, then I get this:

Importing groups
gggggggrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrr[Wed Jan 14
23:42:34 2004] [crit]: 1 (/local/rt3/lib/RT/ACE_Overlay.pm:884)
[Wed Jan 14 23:42:34 2004] [crit]: Can’t load a principal for id
(/local/rt3/lib/RT/ACE_Overlay.pm:885)
rrrrrrrrrrrqqqqqqImporting tickets…t-1
.t-2
.t-3

So, it appears I’ve added the proper line outlined above.

Any clues as to what this error means?

Also, I’m occasionally getting this:

[Thu Jan 15 00:05:55 2004] [crit]: Failed to create user
xxxxxx@domain.com: Name in use (/local/rt3/lib/RT/User_Overlay.pm:600)
[Thu Jan 15 00:06:02 2004] [crit]: Failed to create user
xxxxxx@domain.com: Name in use (/local/rt3/lib/RT/User_Overlay.pm:600)
[Thu Jan 15 00:06:02 2004] [error]: Could not load create a user with
the email address ‘xxxxxx@domain.com’ to add as a watcher for ticket 441
(/local/rt3/lib/RT/Ticket_Overlay.pm:1448)

Russ